4

让网站开发人员头疼的 Internet Explorer 6

如今正在使用IE6浏览器的用户仍然很多,而网站开发工程师们一直致力于让他们的网站能够兼容于 IE6 下的浏览。

针对这种现状,Conveyor Group 的 Ron Goff 和 Kevin Thompson 展开了一个活动:

Save The Developers – Say No To IE 6

让网站开发人员头疼的 Internet Explorer 6

我们这个活动主要致力于协助现在仍然在使用 Internet Explorer 6 的用户来升级他们的浏览器。通过这个活动,我们希望能够让之前仍然在使用 IE6 的用户在升级后,能够体验更愉快的网上冲浪,同时(希望)能够通过这些用户此举(升级他们已经过时的浏览器)来缓和一直以来网络开发工程师们面临的紧张复杂的局面。

如果您也觉得我们的活动有意义,那你可以告诉你周围的人们,他们升级 IE 浏览器的重要性。或者,你可以把我们检测浏览器版本/推荐升级浏览器的脚本添加在你的网站上。

当使用IE6浏览器的用户浏览你的网站的时候,这个脚本自动运行,并且自动弹出展开一个窗口。

让网站开发人员头疼的 Internet Explorer 6

而当用户点击这个窗口,会打开 Save The Developers 的站点,用户在那里可以选择他们要升级的浏览器。

根据 Erick Schonfeld 在 TechCrunch发布的统计

IE7 作为微软浏览器的较新的版本面世也已经两年多了,但是相比 IE7 22% 和 Firefox 36.5% 的市场占有率来说,IE6 仍然有31%。如此缓慢的升级速度,对于程序员来说是很难接受的,因为他们要确保他们设计的Web Apps 要在 5 个不同的浏览器下全部能正常工作。而除此之外,IE6 支持的一些非标准的特性和功能,其它的浏览器是并不能够兼容的。IE6 的安全漏洞也是一个很大的问题。

让网站开发人员头疼的 Internet Explorer 6

上面的统计数据是来自 w3chools 。而根据访问 LiveSide 的统计数据:

让网站开发人员头疼的 Internet Explorer 6

这个根据前一个月访问 LiveSide 的统计数据(二月/三月)。我们能够发现,来自 LiveSide 的统计数据和来自 W3schools 的统计数据基本上是吻合的一点是(二月份 IE 占总数的54.4%),IE 是使用人数最多的,远远多于使用 FF 的用户,并且,试用 IE 浏览 LiveSide 的用户数比例还要稍微高一些。而最大的不同点是浏览 LiveSide 的 IE 浏览器用户中反而是 IE7 的用户要多于 IE6。

那么为什么大家不升级到 IE7 呢?可能有人说他们的操作系统没有办法安装 IE7,那么为什么有些人可以?也有可能他们只是单纯的不喜欢使用 IE7,不喜欢 IE7的外观等等…..或者是 IE 7 并没有感觉到很大的压力。那么不知道当具备了很多新的功能特点标准的兼容性改进了的地址栏等等特点的IE8正式发布的时候,足不足以吸引这些人升级(如果他们的操作系统允许的前提下)。

让网站开发人员头疼的 Internet Explorer 6

普通的用户不会在意网站的开发人员是不是想尽了办法让自己的网站在他们浏览时所使用的浏览器下能够兼容并且足够稳定和方便使用。可能一些现成的特点能够转变他们的想法……

让网站开发人员头疼的 Internet Explorer 6

更多 Activities : (Ebay, FaceBook, StumbleUpon, MSNBC 以及更多…)

一个只是备选的浏览器会有一天成为一个最常被人使用的浏览器么?模块化的 Windows 7会有什么不同之处(笔者猜测IE会是一个单独的模块,但猜测仅仅是猜测)?而一个并非标准的(备选的)浏览器若想成为一个最常被人使用的,它需要先让使用计算机的几乎所有人都先要知道它的存在,然后才有机会知道它是否是最好的浏览器(安全性、使用特点、便捷性、很快的打开速度和标准的兼容性)。

Firefox 或者说是 Opera,最近都宣布了,在 Acid3 测试(一个测试浏览器能够达到特定的网络标准的程度的测试)中达到了 100% 的通过率。最近,Safari 3.1 通过安装了 Apple Updater(iTunes 和 Quicktime 升级)的用户,作为特定更新被升级安装。而这个升级会不会带来更多的Safari用户群?使用 Safari 浏览器的用户根本打不开很多的微软网站站点,包括 Windows Live Hotmail,并且无法播放Flash。而 IE 8 在标准模式下也无法打开一些微软站点,好在还有模拟 IE7 模式。

安装上面提到的浏览器的安装条件:

Internet Explorer 7 – Windows XP Service Pack 2 (SP2), Windows XP专业版 x64, Windows Server 2003 Service Pack 1 (SP1) 和 Windows Vista

Firefox -Windows 98,Windows 98 SE、Windows Me,Windows NT 4.0,Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Mac OS X 10.2.x 和更高版本, Linux

Safari- Windows XP, Windows Vista, Mac

Opera -Windows 95 和所有高于 Windows 95 的操作系统(建议使用Windows 98或更高), Mac, Linux

所以如果你用的操作系统版本低于 Windows XP 并且不想使用 IE6,那么你可以选择 Firefox 或者 Opera。
微软决定 Windows XP 的销售截止到 2008 年的 6 月 30 日,所以使用 IE6 的用户数会很快急剧减少。因为所有6月30日之后购买新的预装 Windows 操作系统的用户,操作系统会是集成了 IE7 的 Windows Vista。
如果你是网站开发人员,并且你也有同样的想法,希望IE8不断地发展成为更好的浏览器,看看IE8 Beta1 的发布,并在安装之前,阅读IE8 Beta 1 的发布说明

IE8 的安装环境:Windows XP Service Pack 2 (SP2), Windows Server 2003 Service Pack 2 (SP2), Windows Server 2008, Windows Vista, Windows Vista Service Pack 1 (SP1)。

LiveSide: Save the Developers! Stop Using Internet Explorer 6

4 条评论

发表评论

您正在使用 IE 6 浏览器访问本博客。简单几步,您就可以升级:Internet Explorer

X